OpenTTD

Tasklist

FS#6620 - The letters 'n' and 'ñ' have noticeably different base letter sizes (Large Sprite Font).

Attached to Project: OpenTTD
Opened by James (james1101) - Wednesday, 06 September 2017, 01:28 GMT
Last edited by frosch (frosch) - Monday, 11 September 2017, 18:32 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 1.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To Reproduce:
1. Use the sprite font and the spanish language.
2. Start OpenTTD and do new game.
3. Wait until a 'subsidy offered' message appears. (You may have to disable Cargodist to enable Subsidy creation.)
4. Click on it.
BUG: The letters 'n' and 'ñ' have noticeably different base letter sizes. (n: 10px * 8px; ñ: 15px * 10px with a total size of 15px*14px)

Possible Reason: When drawing the sprite font, in Spanish, the person who was doing the 'ñ' sprite decided to upscale it by a factor of ~1.5.

Suggested Fix: Have someone redraw the sprite, scaled back down to the 10px width of the 'n' sprite.

In the attached image, red-underlined letters are the relevant ones for this bug report.

OpenTTD Version 1.7.1 running on Win 7 Ultimate.
This task depends upon

Closed by  frosch (frosch)
Monday, 11 September 2017, 18:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r27915
Comment by frosch (frosch) - Sunday, 10 September 2017, 15:19 GMT
I cannot reproduce this.
The font in the screenshot does not look like any sprite font from any baseset I know.

Please attach your openttd.cfg, or at least these settings:
* language
* large_size
* large_aa
* large_font
* graphicsset
* gui_zoom
Comment by Grzegorz Duczyński (adf88) - Sunday, 10 September 2017, 16:05 GMT
It looks like you've set a font in your openttd.cfg, but it doesn't have the 'ñ' character or it fall-backs somehow otherwise to such a font.

The 'ñ' letter in the text was rendered using its default picture which means that is has the default size (not the one you've set in openttd.cfg). However, the rest of letters are a bit smaller then the default ones which means that a custom font was used.

You may try experimenting with different 'large_font' and 'large_size' settings.

You can also try running OpenTTD in console through 'openttd.exe -d freetype=2' to get some more info about what font was picked exactly.
Comment by James (james1101) - Sunday, 10 September 2017, 19:10 GMT
I've attached my openttd.cfg and the default version. Using the default settings, the ñ is still a bit larger, but only in the large newspaper font.
Comment by frosch (frosch) - Monday, 11 September 2017, 17:52 GMT
Ok, the triggering combination is:
* OpenGFX baseset
* Spritefont

Loading...