OpenTTD

Tasklist

FS#647 - Build-on-slope graphics garbled except in temperate

Attached to Project: OpenTTD
Opened by andythenorth (andythenorth) - Sunday, 25 February 2007, 10:18 GMT
Last edited by Remko Bijker (Rubidium) - Friday, 09 March 2007, 03:00 GMT
Type Bug
Category Interface
Status Closed
Assigned To Bjarni (Bjarni)
Operating System Mac OS X
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Track sprites are drawn incorrectly / garbled when building on slopes in Arctic & Desert climates.
- Fine in temperate.
- All newGRF files deactivated.
- Reproducible both with enhanced build-on-slopes patch on AND off.
- screenshots attached.

Happens in all v5 RC 2, 3, 4 and 5. Didn't happen in v4.
OS X (x86) using original data files from TTD Windows.
This task depends upon

Closed by  Bjarni (Bjarni)
Saturday, 10 March 2007, 18:30 GMT
Reason for closing:  Not a bug
Comment by Darkvater (Darkvater) - Saturday, 03 March 2007, 12:53 GMT
Does not happen here, please check a clean install and/or 0.5.0 final. I'm assigning this to Bjarni as it could be an endiannes problem?
Comment by Bjarni (Bjarni) - Friday, 09 March 2007, 13:13 GMT
doesn't look like an endian issue
Comment by andythenorth (andythenorth) - Saturday, 10 March 2007, 16:51 GMT
Resolved this - I had a newGRF file (trkfoundw.grf) in my data folder. It was not activated in openTTD cfg, but removing it appears to have resolved the issue.

Loading...