OpenTTD

Tasklist

FS#6100 - Constant crashes in multiplayer, probably chat related

Attached to Project: OpenTTD
Opened by David Dallaston (Pikka) - Friday, 29 August 2014, 11:25 GMT
Last edited by frosch (frosch) - Tuesday, 02 September 2014, 17:12 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity High
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is a proper report version of  FS#5937 . The crash still happens in the current nightly (r26761)

The crash can be reliably caused by opening the chat input, entering a single character (eg "o" or "3") and pressing enter. It also crashes "randomly" at other times with the same error message.

I also have a bug where the first character of chat messages is company coloured (see attached image), which I suspect is related. I also suspect this bug is hardware/setup dependent, since other people I've asked do not have the crash and do not have the miscoloured chat text.
This task depends upon

Closed by  frosch (frosch)
Tuesday, 02 September 2014, 17:12 GMT
Reason for closing:  Bug in external library
Additional comments about closing:  ICU having trouble with Calibri
Comment by Marctraider (Marctraider) - Friday, 29 August 2014, 16:25 GMT
Wonder if its related to my bug report i filed a few days ago.

/task/6096

Same correlation with Chat + Multiplayer.
Comment by David Dallaston (Pikka) - Sunday, 31 August 2014, 18:08 GMT
This appears to have been a problem with the font I was using (Calibri). I changed it and the problem went away...
Comment by Marctraider (Marctraider) - Tuesday, 02 September 2014, 17:07 GMT
Odd. Still, since the crash I discovered is also related closely to fonts, chat boxes, I still have a feeling its related :p

I could be totally wrong though.
Comment by frosch (frosch) - Tuesday, 02 September 2014, 17:12 GMT
Calibri has been an issue before:  FS#5711 

Loading...