OpenTTD

Tasklist

FS#5520 - Assertion error upon Station tile removal

Attached to Project: OpenTTD
Opened by Vaclav Benc (V453000) - Wednesday, 03 April 2013, 13:26 GMT
Last edited by Remko Bijker (Rubidium) - Saturday, 06 April 2013, 18:30 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Once upon a time, r25137 crashed, and he nutjobs lived sad ever after.

On another note, here I have a savegame with !this tile. When removing that tile, the game crashes.

In the earlier stages of the game there was a vehicle on that tile, overwritten with this inaccessible ISR station tile later on.

We had this problem with 25130, then we updated to 25137 later.

Apparently there is something with reserving going on which somehow does not get unstuck.

Removing ISR causes the station can be removed freely without issues.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Saturday, 06 April 2013, 18:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r25152
Comment by Transportman (Transportman) - Wednesday, 03 April 2013, 16:29 GMT
Looks like a duplicate of #5510, #5516 and #5518.

It is indeed a stray reservation, and the cause of that stray reservation has been removed in r25132, but games with that stray reservation still crash when removing the tiles affected, see also the comment of Rubidium in #5518.

Loading...