OpenTTD

Tasklist

FS#5457 - Aircraft Model Life calculations stop in 2054

Attached to Project: OpenTTD
Opened by David Dallaston (Pikka) - Wednesday, 30 January 2013, 11:23 GMT
Last edited by Peter Nelson (peter1138) - Wednesday, 30 January 2013, 11:58 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Aircraft model life calculations seem to stop around 2054-2055; aircraft model which are in "phase 3" decline at the end of 2054 will stop losing reliability and will not be removed from the purchase list.

I checked egrvts and road vehicles appear to continue losing reliability through this date, as they should. I have not checked other vehicle types.

Attached is a test grf with two aircraft, both introduced 2040 with a 10 year model life. The difference between the two aircraft is that one has the long-format intro date set (prop 1A), and the other does not. It doesn't make any difference.
This task depends upon

Closed by  Peter Nelson (peter1138)
Wednesday, 30 January 2013, 11:58 GMT
Reason for closing:  Not a bug

Loading...