OpenTTD

Tasklist

FS#455 - Converting to monorail behaves badly

Attached to Project: OpenTTD
Opened by Anonymous Submitter - Tuesday, 19 December 2006, 19:30 GMT
Type Bug
Category Vehicles → Electrified rails
Status Closed
Assigned To No-one
Operating System Windows
Severity High
Priority High
Reported Version 0.5.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just got into the year 2000 and i am rewarded with the new monorail :D
So i started to convert track by track to monorail, until i saw stuff piling up in almost all my stations.
I took a look, and about 50% of the tracks from my map where auto-converted to monorail, except the part of the track the train was currently on.

Seeems to me a major bug...

Jan
This task depends upon

Closed by  Darkvater (Darkvater)
Sunday, 31 December 2006, 03:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  not a bug.
Comment by Darkvater (Darkvater) - Thursday, 21 December 2006, 13:32 GMT
That is perfectly allright. If you were to convert your rail to monorail, the trains won't even move and will never move because they have incompatible railtypes.
Comment by GreatBunzinni (GreatBunzinni) - Saturday, 23 December 2006, 11:39 GMT
I don't see it as a bug. Regular trains don't run on monorail tracks and it isn't exactly practical to upgrade a train track to monorail when a train is on it. Moreover, why would all the trains get upgraded while performing cargo runs?

Maybe next time you could simply call the trains into the train repository, convert the tracks, take care of the repository and the trains and then move on. It seems the logical thing to do.

Loading...