OpenTTD

Tasklist

FS#2378 - assertion in pbs.cpp:139

Attached to Project: OpenTTD
Opened by Nathanael Rebsch (dihedral) - Wednesday, 22 October 2008, 17:18 GMT
Last edited by Loïc GUILLOUX (glx) - Wednesday, 22 October 2008, 23:07 GMT
Type Bug
Category Vehicles → PBS
Status Closed
Assigned To Michael Lutz (michi_cc)
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version 0.7.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

openttd: /home/fairplay/openttd/src/pbs.cpp:139: void UnreserveRailTrack(TileIndex, Track): Assertion `(GetTileTrackStatus(tile, TRANSPORT_RAIL, 0) & TrackToTrackBits(t)) != 0' failed.

r14508

merely unpause the save ;-)
This task depends upon

Closed by  Loïc GUILLOUX (glx)
Wednesday, 22 October 2008, 23:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r14521.
Comment by Nathanael Rebsch (dihedral) - Wednesday, 22 October 2008, 17:22 GMT
the first assert was
openttd: /home/fairplay/openttd/src/rail_map.h:501: bool HasSignalOnTrackdir(TileIndex, Trackdir): Assertion `IsValidTrackdir(trackdir)' failed.
(before we tried to reproduce it)
Comment by NukeBuster (NukeBuster) - Wednesday, 22 October 2008, 17:33 GMT
It seems it is only happening on maglev tracks.
Comment by Zdeněk Sojka (SmatZ) - Wednesday, 22 October 2008, 20:42 GMT
Caused by call to GetVehicleTrackdir() for crashed vehicles (happens at two or more places, so there are different assert messages)

Loading...