OpenTTD

Tasklist

FS#1868 - Cannot move wagon before first (free) wagon

Attached to Project: OpenTTD
Opened by Alberth (Alberth) - Friday, 21 March 2008, 13:37 GMT
Last edited by Remko Bijker (Rubidium) - Thursday, 24 April 2008, 21:12 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In revision 12386:

In the depot, there is 1 locomotive with a bunch of wagons after it. On the line below are two wagons already. I want to pick up a wagon from the top line, and drop it on the line below. If I drop it onto, or at the right of the right-most wagon, it works. If I drop the wagon onto the first wagon, it doesn't work (I expect the dropped wagon to become the first wagon, and the two wagons on the second line to shift one to the right).
The above operations *both* work when there is also a locomotive at the second line.
This task depends upon

Closed by  Jean-Francois Claeys (Belugas)
Tuesday, 06 May 2008, 17:01 GMT
Reason for closing:  Not a bug
Additional comments about closing:  as glx explained
Comment by Jean-Francois Claeys (Belugas) - Friday, 21 March 2008, 13:41 GMT
Could it be that you have a grf that actually prohibits this kind of mix?
You did not specitied any comment on the matter
Comment by Alberth (Alberth) - Friday, 21 March 2008, 13:53 GMT
No NEWgrfs. I do have a number *.tar files with 32bpp graphics though. Yesterday, I asked at #openttd, and Gonzales_VIII seemed to have the same problem.
Comment by Loïc GUILLOUX (glx) - Friday, 21 March 2008, 18:18 GMT
The first free wagon is handled as an engine, that's why you can't move a wagon in front of it. Same happens for "real" trains (the ones with an engine), you can't move a wagon before the engine. But you can move the engine after a wagon :)

Loading...