OpenTTD

Tasklist

FS#1476 - Building water_tower not permitted with multiple ind. per town

Attached to Project: OpenTTD
Opened by SirkoZ (SirkoZ) - Friday, 23 November 2007, 20:50 GMT
Last edited by Jean-Francois Claeys (Belugas) - Monday, 07 January 2008, 16:58 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version 0.6.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi!

Release: 0.6.0-beta1

A funny bug really - with multiple industries per town one can easily build a diamond mine near a bank, a water supply near water tower but one can not build a water tower in a town that has a water supply a few squares from its center.

An oddity at best. :-)

Regards

SirkoZ
This task depends upon

Closed by  Jean-Francois Claeys (Belugas)
Wednesday, 09 January 2008, 18:23 GMT
Reason for closing:  Not a bug
Additional comments about closing:  As agreed, closure of the bug, as it is not one, but a limitation of the system, which is not relevant to the patches activated
Comment by SirkoZ (SirkoZ) - Friday, 23 November 2007, 20:54 GMT
Oh my - just now I've been going through the industry_cmd.cpp and saw this:

/* accepting industries won't be close, not even with patch */
if (_patches.same_industry_close && indspec->accepts_cargo[0] == CT_INVALID)
return true;

Could one please explain to me why not - I mean - could you at least make an exception for the water tower, because it's really impossible to grow a desert town that has a water supply near it (with multiple industries per town patch ON) - and sometimes it would really useful to grow it...
Comment by Jean-Francois Claeys (Belugas) - Monday, 07 January 2008, 04:07 GMT
The code is like that since r1 of current trunk.
But, looking at my archives, i found out it has not always been that way. in r607 (pre-crash), there was not accepts_cargo test.

I suspect that the arrival of the option "same_industry_close" may have made the game too easy.
And it has been the decision of the dev at that time to limit the user in forbidding placing any industries near primary ones (extractive or organic).
My assumption is that factories were funded close to farms, producing countless bundles of goods/foods.

The only thing, apart removing the test, is to change it to if (_patches.same_industry_close && indspec->life_type == INDUSTRYLIFE_ORGANIC),
which will allow to process extractive industries.
Don't know, it's the best i can think of right now
Comment by SirkoZ (SirkoZ) - Monday, 07 January 2008, 08:44 GMT
Yes - that would be just right.
All I wanted was if the switch is ON and someone is using that water supply for the other to be able to grow that town (if it's a desert town).

Thx.
Comment by Jean-Francois Claeys (Belugas) - Monday, 07 January 2008, 16:57 GMT
You're missing the point. The point is why the code has been changed to be the one we have right now.
So, it is more about finding the original intent then fixing your issue. Maybe there is no issue at all, and the change was really sane to begin with.
Comment by SirkoZ (SirkoZ) - Tuesday, 08 January 2008, 17:13 GMT
I understand that and also the intention to make things perhaps more challenging, but the whole switch to me looks like a game simplification/appropriate for competition too - but one should still be able to grow desert towns, so your proposed fix looks ok to me.
I don't see it as being sane if one cannot do the same things as with this switch OFF. ;-)
Comment by Jean-Francois Claeys (Belugas) - Tuesday, 08 January 2008, 17:22 GMT
>but the whole switch to me looks like a game simplification/appropriate for competition too
Care to explain?

>but one should still be able to grow desert towns
AS far as i can see, it does not SPECIFICALLY point out to the water tower/supply part. Look at the whole picture.

>I don't see it as being sane if one cannot do the same things as with this switch OFF
I do not follow you at all.
Comment by SirkoZ (SirkoZ) - Tuesday, 08 January 2008, 17:47 GMT
Here's an explanation: if same type of industries close - if one decides to enable it, he does so because he either wants more industries (most cases) or less distance between the industries (for so multi-cargo trains).

-> AS far as i can see, it does not SPECIFICALLY point out to the water tower/supply part. Look at the whole picture.
But it sure acts that way. ;-)
And that's what is at most importance, gameplay, isn't it?
And the whole picture shouldn't change - explanation to the last point of yours ("I do not follow you at all")
If one can build water towers in _any_ desert town without the industries_of_the_same_type_close_together option, one should be able to do that with the switch ON too, wouldn't you say?
It is the player's choice to enable/disable those switches, but gameplay shouldn't be impared with them being ON. And in this case - the gameplay is limited by the fact that if the industries_of_the_same_type_close_together switch being used, in the desert terrain - one could not develop that desert town which has water suply near it.
That is the impared gameplay experience I'm talking about.

Loading...