OpenTTD

Tasklist

FS#1207 - town builds non-connectible roads at hills

Attached to Project: OpenTTD
Opened by Zdeněk Sojka (SmatZ) - Wednesday, 05 September 2007, 20:23 GMT
Last edited by Benedikt Brüggemeier (skidd13) - Thursday, 13 September 2007, 08:04 GMT
Type Bug
Category Core
Status Closed
Assigned To Benedikt Brüggemeier (skidd13)
Operating System All
Severity Very Low
Priority Normal
Reported Version trunk
Due in Version 0.6.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r11047

With 2x2 or 3x3 grid town layout, some roads are built inconnectible to existing roads.
This task depends upon
 FS#1161 - Make town_cmd a bit more readable 

Closed by  Remko Bijker (Rubidium)
Wednesday, 19 September 2007, 18:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11130
Comment by Benedikt Brüggemeier (skidd13) - Wednesday, 05 September 2007, 21:11 GMT
The problem is caused by a template structure in the algorithm which is calulating the grid. This structure will be replaced by a more dynamic solution.  FS#1090  fixes this already, but it does a lot more. After the rewrite of the town growth ( FS#1161 ) the problem should be solved.
Comment by Benedikt Brüggemeier (skidd13) - Thursday, 06 September 2007, 21:40 GMT
The current patch of  FS#1161  should fix the major problem of really inconnective road tiles. There appear still some unaesthetic road junctions. But therefore  FS#1090  exists.
Comment by Benedikt Brüggemeier (skidd13) - Friday, 07 September 2007, 07:50 GMT
So reconvert from  FS#1161  to the old procedure is done. This one should fix it.
Comment by Remko Bijker (Rubidium) - Saturday, 15 September 2007, 09:50 GMT
 FS#1161  does not seem to "solve" this issue and  FS#1090  doesn't apply anymore without a lot of rejects.
Comment by Benedikt Brüggemeier (skidd13) - Saturday, 15 September 2007, 10:08 GMT
 FS#1161  prevents only the generation of new inconnectible roads. I'm already at the rewrite of  FS#1090 .
Comment by Benedikt Brüggemeier (skidd13) - Wednesday, 19 September 2007, 15:15 GMT
This patch will fix the unconnectable roads. It took me a while till I noticed that bypassing the templates solved the problem easily.

Patch against: r11127
Comment by Benedikt Brüggemeier (skidd13) - Wednesday, 19 September 2007, 15:38 GMT
Damn forget to remove some unneeded stuff. Sorry.
Comment by Benedikt Brüggemeier (skidd13) - Wednesday, 19 September 2007, 15:40 GMT
And now I missed to add the file :(
Comment by Benedikt Brüggemeier (skidd13) - Wednesday, 19 September 2007, 15:45 GMT
Hmm, the file does not like to be uploaded. Or flyspray is blocking me.... strange. So next try

Loading...