OpenTTD

Tasklist

FS#5447 - Add a space in this string

Attached to Project: OpenTTD
Opened by Yannis A (Evropi) - Wednesday, 23 January 2013, 01:44 GMT
Last edited by frosch (frosch) - Wednesday, 23 January 2013, 18:13 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

There should be a space between 'None' and '{STRING}' in the string 'STR_VEHICLE_INFO_NO_CAPACITY'.

It currently reads:

{BLACK}Capacity: {LTBLUE}None{STRING}

Wherein {STRING} returns the cargo subtype.
This task depends upon

Closed by  frosch (frosch)
Wednesday, 23 January 2013, 18:13 GMT
Reason for closing:  Not a bug
Additional comments about closing:  intentional behaviour
Comment by Supercheese (Supercheese) - Wednesday, 23 January 2013, 01:48 GMT
I hacked together a reeeeally quick and dirty grf that demonstrates why there should be a space. Steps to reproduce:

1) Load attached grf, start a game at earliest 1930.

2) Build a train depot

3) Build a "police car" in the train depot (as I said, quick and hacky)

4) Click the police car's vehicle information button

5) Click the "capacities" tab

Observe the capacity shows as "None(Siren On)". It should have a space, to make it "None (Siren On)".

I've also observed the other strings immediately below STR_VEHICLE_INFO_NO_CAPACITY in the language file do not have a space in them, such as STR_VEHICLE_INFO_CAPACITY. Other strings, however, do have a space, such as the refit menu strings.
Comment by frosch (frosch) - Wednesday, 23 January 2013, 18:13 GMT
This is normal behaviour for subtypes.
Subtypes always appear right after the cargo, no matter whether it is "None" or a real cargo.

While this may be stupid, it is the historically defined behaviour of TTDPatch and all existing GRF have spaces in front of their subtypes.
Comment by frosch (frosch) - Wednesday, 23 January 2013, 19:46 GMT
The inconsistency with the refit GUI was fixed in r24938.

Loading...