OpenTTD

Tasklist

FS#4695 - [OS X 10.7] Crash on switching to fullscreen mode

Attached to Project: OpenTTD
Opened by Bene (tigashy) - Sunday, 24 July 2011, 09:41 GMT
Last edited by Ingo von Borstel (planetmaker) - Sunday, 28 August 2011, 08:35 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Medium
Priority Normal
Reported Version 1.1.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

I've just installed Mac OS X 10.7 Lion this week and tested OpenTTD on it.
The Game itself runs fine just as with 10.6 Snow Leopard. But as soon as you switch to fullscreen mode, the game crashes (you have a black screen then and can only quit the game by pressing command+alt+esc). I'm sure there's some problem with the new fullscreen feature of lion and how the system handles full screen apps.

It's not a critical bug for me because I'm usually not playing the game in fullscreen but there may be other who want to do so on Lion.

Chrashfiles are attached.
This task depends upon

Closed by  Ingo von Borstel (planetmaker)
Sunday, 28 August 2011, 08:35 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Same issue as  FS#4744  - fixing that will also fix this.
Comment by Sander Evers (sanderevers) - Monday, 15 August 2011, 11:11 GMT
Confirmed, it's really annoying on Lion.
Comment by William G (williamg) - Thursday, 25 August 2011, 02:42 GMT
Almost certainly related to  FS#4744 

Loading...