OpenTTD

Tasklist

FS#4599 - Parameters for fatal NewGRF message not properly used

Attached to Project: OpenTTD
Opened by Ingo von Borstel (planetmaker) - Saturday, 23 April 2011, 05:54 GMT
Last edited by frosch (frosch) - Sunday, 03 July 2011, 14:32 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Custom NewGRF error messages (0xFF) don't use the STRING parameters properly, instead OpenTTD generates the output
dbg: [grf] Unknown StringID 0xFFFF remapped to STR_EMPTY. Please open a Feature Request if you need it

Test case: OpenGFX+ Industries and Pikka's Basic Industries used jointly will generate it.

[23:49] Yexo planetmaker: after a lot of recompiling I can't trigger that bug anymore
[23:49] Yexo if you can still reproduce the " is incompatible with ." bug please open a bug at fs so I don't forget to look at it
[23:51] planetmaker hm... I get it everytime. You have with ogfx+industries head now a test case
[23:51] planetmaker actually... once with the agricultural vector of ECS I even got "Food processing plant is incompatible with ."
[23:52] planetmaker dbg: [grf] Unknown StringID 0xFFFF remapped to STR_EMPTY. Please open a Feature Request if you need it <-- console
[00:00] Yexo that is even reproducible in 1.1.0 :(

This task depends upon

Closed by  frosch (frosch)
Sunday, 03 July 2011, 14:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r22629
Comment by Thijs Marinussen (Yexo) - Saturday, 23 April 2011, 19:15 GMT
The problem is in ErrmsgWindow, it doesn't call SwitchToErrorRefStack often enough. There might be more related problems in that class, since I'm not sure if SwitchToNormalRefStack is always called before leaving code related to this class. The exact effects of leaving out the call to SwitchToNormalRefStack are unclear to me at the moment.

Loading...