OpenTTD

Tasklist

FS#3754 - it's possible to join server without knowing server password

Attached to Project: OpenTTD
Opened by Zdeněk Sojka (SmatZ) - Sunday, 11 April 2010, 14:09 GMT
Last edited by Zdeněk Sojka (SmatZ) - Wednesday, 14 April 2010, 16:55 GMT
Type Bug
Category Core
Status Closed
Assigned To Zdeněk Sojka (SmatZ)
Operating System All
Severity Critical
Priority Normal
Reported Version 1.0.0
Due in Version 1.0.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The problem is in DEF_SERVER_RECEIVE_COMMAND(PACKET_CLIENT_PASSWORD)...
maybe we should split STATUS_AUTHORIZING to STATUS_AUTHORIZING_SERVER and STATUS_AUTHORIZING_COMPANY, or so

How to reproduce - with passworded companies:
start server, server password 'XXX'
start new company, company password 'YYY'
join with patched client to the company, password 'YYY' is enough - needs join_server_hack.diff

How to reproduce - with unpassworded companies:
start server, server password 'XXX'
join with patched client to the company - needs join_server_hack_2.diff
This task depends upon

Closed by  Zdeněk Sojka (SmatZ)
Wednesday, 14 April 2010, 16:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r19607, needs backporting
Comment by Zdeněk Sojka (SmatZ) - Sunday, 11 April 2010, 17:17 GMT
should be fixed by r19607, let's wait with closing this task

Loading...