OpenTTD

Tasklist

FS#704 - Autoreplace causes crash with all vehicles expect for trains in r9413

Attached to Project: OpenTTD
Opened by Ailure (Ailure) - Friday, 23 March 2007, 23:11 GMT
Type Bug
Category Vehicles → Autoreplace
Status Closed
Assigned To No-one
Operating System All
Severity Critical
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Seems to happen in certain circumstances, seems to happen with aircraft, road vehicles, boats but not with trains. A easy way of reproducing bug is simple starting in temperate at year 1970, build a bus and then open up the autoreplace window for road vehicle. The game will crash instantly usually.
This task depends upon

Closed by  Loïc GUILLOUX (glx)
Friday, 30 March 2007, 21:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  r9528
Comment by Ailure (Ailure) - Wednesday, 28 March 2007, 15:53 GMT
Still happens in r9504, using the Win32 version if it helps. Someone under Linux (sorry forgot name) tried the bug, but it didn't crash for him so the bug might only happen on Win32.
Comment by Celestar (Celestar) - Friday, 30 March 2007, 20:24 GMT
I seem to be unable to reproduce the bug (linux as well) either.

Loading...