OpenTTD

Tasklist

FS#684 - Manual Replace button replaces not stopped vehicles

Attached to Project: OpenTTD
Opened by Johannes E. Krause (Eddi) - Friday, 16 March 2007, 00:45 GMT
Type Bug
Category Vehicles → Autoreplace
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

i'm not completely sure if that might be intended behaviour.

assume i have 2 engines 'A' and 'B' available, and i have currently 2 trains '1' and '2' with engine 'A' in the depot.

'1' is stopped in the depot.
'2' is set to go, but is currently unable to do so (exit blocked)

i set up a replacement rule from 'A' to 'B'
and now i hit the "upgrade" button in the depot

now it replaces the engine of the train '1' as expected
but it also replaces the engine of train '2', while one would expect, that autoreplace for train '2' fails, because it is not stopped (selling, moving wagons etc. don't work either).
This task depends upon

Closed by  Bjarni (Bjarni)
Friday, 16 March 2007, 09:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  I coded it like this on purpose. It will (like completely automated autoreplace) stop and start the vehicles without the user being able to notice this.

Loading...