OpenTTD

Tasklist

FS#6680 - Refinery maxed at 33-34,000 goods

Attached to Project: OpenTTD
Opened by Netmax (NetMax) - Monday, 26 February 2018, 21:46 GMT
Last edited by andythenorth (andythenorth) - Sunday, 04 March 2018, 09:18 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.7.2
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Objective was 100,000 goods from a refinery. Got up to 34,000 with 1/2 my trains. Added the rest of the trains and the goods stayed around 34,000. Added ships and the refinery output still stayed around 33,000 to 34,000. It should be well over 90,000 with all the oil being delivered. TIA

Running W7 Pro. Isolated pc (game-only machine), so no internet connection or antivirus running.
This task depends upon

Closed by  andythenorth (andythenorth)
Sunday, 04 March 2018, 09:18 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not a bug. As you discovered, this is the upper limit in the implementation.

https://www.tt-forums.net/viewtopic.php? t=48156
Comment by Netmax (NetMax) - Wednesday, 28 February 2018, 16:44 GMT
Some more data points. I pulled the main stations (EastRef & Westref) 4 squares apart and set up 2 refineries. Now both are at 30,000+ goods (still low). The interesting aspect is these refineries are accepting oil from the main stations which are 12 squares away (?!). The north station is receiving the goods. The 2 south stations (docks) are supplying the oil (from 6 rigs). EastRef and WestRef are each fed by 20 rigs at around 600,000 litres/month. I don't know the conversion between litres & goods, but a total of 46 rigs at 600,000 litres (27.6 million litres would seem to be more than the 60,000 goods being produced at 76-80% efficiency. New files attached.
Comment by Netmax (NetMax) - Saturday, 03 March 2018, 17:27 GMT
Update: A day's length is 74 ticks. Every 256 ticks there is 1 callback when factories, refineries etc produce 255 items per tile (ie: 3x5 refinery = 15 tiles).

Example, a 31 day month = 2,294 ticks = 9 callbacks, x 255 items = 2,295 items/tile, x 15 tiles = 34,425 items/month max from a 15 tile refinery.

This is not a bug, it's a limiting characteristic. There was work on a patch which lets you increase the number of ticks per day. I don't know the status or compatibility of these patches with vers. 1.7.2, but I hope this helps others with understanding production outputs.

Loading...