OpenTTD

Tasklist

FS#6615 - Crash: [OS X] "Segmentation fault"

Attached to Project: OpenTTD
Opened by jmgazzoli (jmgazzoli) - Thursday, 24 August 2017, 03:39 GMT
Last edited by andythenorth (andythenorth) - Wednesday, 30 August 2017, 20:00 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Medium
Priority Normal
Reported Version 1.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The game works fine for awhile then suddenly crashes.
This task depends upon

Closed by  andythenorth (andythenorth)
Wednesday, 30 August 2017, 20:00 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Frosch thinks this is likely a duplicate of FS#6322. Possibly an issue with AIs trying to allocate too much memory for 32 bit build with 32bit blitter.
Comment by jmgazzoli (jmgazzoli) - Thursday, 24 August 2017, 04:24 GMT
It happened again. A serious fault.
Comment by andythenorth (andythenorth) - Wednesday, 30 August 2017, 20:02 GMT
Issue might be resolved (in the short term) by switching to the 8bpp blitter. Basic instructions here https://wiki.openttd.org/FAQ_troubleshooting#My_system_is_horribly_slow_with_OpenTTD_1.5_or_later

Loading...