FS#6366 - Windows 10 main viewport and mouse issues in fullscreen mode

Attached to Project: OpenTTD
Opened by Ricardo (Samu) - Monday, 24 August 2015, 13:06 GMT
Last edited by Michael Lutz (michi_cc) - Monday, 13 March 2017, 22:04 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version 1.5.2-RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Hi. I recently upgraded to Windows 10, from Windows 7. There are two major issues I found out right away.

1. Right clicking to drag the viewport is very unresponsive, it doesn't pan the screen at ease, it's stuttering, like there's some grip to it. This happens in both fullscreen mode and in windowed mode.

2. When running the game in fullscreen mode, I don't have access to the toolbars at the top and the bottom of the screen, it looks like the viewport is confined to the inner center. Mouse cursor can only interact inside that confinement.

I attach two screenshots to better explain what is happening with point 2:
- The first one is taken from the in-game tool using Ctrl-S. It does not reflect what I see on my display.
- The other is what I really see, some kind of inner window confining the mouse and anything I can interact.
This task depends upon

Closed by  Michael Lutz (michi_cc)
Monday, 13 March 2017, 22:04 GMT
Reason for closing:  Implemented
Additional comments about closing:  In r27790 and r27791.
Comment by Ricardo (Samu) - Wednesday, 26 August 2015, 11:31 GMT
I solved both problems. It was a compatibility problem.

- Right click OpenTTD shortcut, left click Properties
- Left click Compatibility tab
- Check Disable display scaling on high DPI settings
- Click OK

Now it scrolls fine, no more stuttering, and I can access the building tools in fullscreen mode.

May I suggest when installing the game on Windows 10, to create a shortcut with "Disable display scaling on high DPI settings" checked? Is it feasible?
Comment by John (coyoteelabs) - Monday, 28 December 2015, 10:34 GMT
Wouldn't the problem be better solved by marking OpenTTD as "Dpi Aware"? The automatic scaling is because Windows sees the game as non-dpi aware and scales it. Adding a manifest file that specifies the game is dpi aware should stop Windows from applying the dpi scaling so the workaround with the compatibility tab should no longer be needed.

Microsoft has instructions and a manifest example here:
Comment by Ricardo (Samu) - Thursday, 31 March 2016, 02:34 GMT
This works for me, tested it on Windows 10 with a 125% scaling and OpenTTD 1.6.0-RC1.
Comment by Ricardo (Samu) - Sunday, 17 April 2016, 10:45 GMT
Uploading a better patch, for all builds. And uploading a video displaying 640x480 side by side with version nightly r27540 and patched r27540 trunk.
Comment by Mete (Metebacsi) - Sunday, 24 December 2017, 12:21 GMT
On Windows 7 Home Premium SP1 the options on the compatibility tab are grayed out for changing the display scaling settings. I see that Ricardo got a patch that fixed for windows 10, is there a way to get it fixed for both operating systems? ^^
For me currently the scrolling and map panning are barely functional ^^