OpenTTD

Tasklist

FS#6273 - A ship got stuck in a Fishing Grouds

Attached to Project: OpenTTD
Opened by Henrik (Gankenstein) - Sunday, 05 April 2015, 15:00 GMT
Last edited by andythenorth (andythenorth) - Monday, 21 August 2017, 18:59 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 1.5.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

A ship under way got stuck in some Fishing Grounds. And by stuck I mean the ship keeps moving back and forth between two (diagonally) adjacent tiles inside the Fishing Grounds. These particular Fishing Grounds were not present when the ship was acquired and assigned a schedule, and the do not figure in the ship's route, nor have they ever.

I have tried sending the ship to dock and also tried building a buoy and sending the ship there, but that did not change the ship's behaviour.

It is possible that the Fishing Grounds spawned while the ship was crossing their location and the ship got caught within the bounding box of the Fishing Grounds.

Also reported here: https://www.tt-forums.net/viewtopic.php?f=31&t=72881

The scenario used for this game is this: https://www.tt-forums.net/download/file.php?id=184300 which then had start date changed to 1900 and industries sprinkled on it. Relevant NewGRFs: FISH 0.9.2 and FIRS 1.4.3

OS Win7, 64 bit.
OTTD version 1.5.0
This task depends upon

Closed by  andythenorth (andythenorth)
Monday, 21 August 2017, 18:59 GMT
Reason for closing:  Won't fix
Additional comments about closing:  frosch123: i doubt ottd will ever check for ships being trapped when placing an object

I looked if it was possible to change FIRS to avoid this. It's not afaict.

Flyspray clean up: closing this as it's only been reported once, is hard to repro the cause, and is unlikely to be fixed.

Comment by andythenorth (andythenorth) - Monday, 21 August 2017, 19:02 GMT
I did try to repro this by placing FIRS Fishing Grounds over ships, but I couldn't trigger it.

Loading...