OpenTTD

Tasklist

FS#6002 - Savegame error

Attached to Project: OpenTTD
Opened by Ricardo (Samu) - Wednesday, 30 April 2014, 15:49 GMT
Last edited by frosch (frosch) - Wednesday, 07 May 2014, 17:34 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

OpenTTD r26540.
Windows 7 Ultimate 64-bit with SP1

There are two ways to reproduce this.
1. Launch OpenTTD
2. Start new game
3. Save the game
R. It will error with "Game Save Failed... File not writeable". No matter what name I put it, it won't save at all.


Or, worse, this one ate me a real save game that I needed
1. Launch OpenTTD
2. Load a game
3. Save the game with a different name
R. It saves the game, but instead of saving it as the name suggested, it will overwrite the loaded game instead. The saved game is saving the current game correctly, though.
This task depends upon

Closed by  frosch (frosch)
Wednesday, 07 May 2014, 17:34 GMT
Reason for closing:  Unreproducible
Comment by Tim Lyth (mrtux) - Tuesday, 06 May 2014, 03:30 GMT
What is the full path to the save location in scenario 1?
And is it the same path for scenario 2?

Also, how much free space do you have on the drive that you are trying to save files to?

I've been running OTTD on Win 7 Ultimate 64-bit without either of those issues ever occurring, although it was quite a few months ago when I last played it and was one of the 1.3.x series rather than 1.4.x.
Comment by Ricardo (Samu) - Wednesday, 07 May 2014, 08:57 GMT
It was the same path in both examples. The loaded game was also on the same place as the save files.
C:\Users\Ricardo\Documents\OpenTTD\save
353 GB free space

The error was only happening on r26540, but not on 1.4.0. I can try a newer version, to see if it's happening again, but I can't try r26540 again, don't know where to find it, already deleted this.
Comment by Ricardo (Samu) - Wednesday, 07 May 2014, 09:07 GMT
Just tested. It is not happening on r26565 nor on 1.4.1-RC1.
EDIT: I found r26540 again, it's doing the same errors.

Looks like the issue is fixed in newer versions.

Loading...