OpenTTD

Tasklist

FS#6001 - can build as company 1 when restarting server while being a spectator

Attached to Project: OpenTTD
Opened by Ricardo (Samu) - Monday, 28 April 2014, 19:31 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 11 May 2014, 13:07 GMT
Type Bug
Category Network
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.4.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is easy to reproduce.

1 - launch openttd
2 - multiplayer > start > new game > generate
3 - move yourself from company 1 to spectator
4 - enter 'restart' in console

Result: I can build as company 1 after the restart, while the client list isn't listing me in company 1, but as a spectator.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Sunday, 11 May 2014, 13:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r26577
Comment by Ricardo (Samu) - Monday, 28 April 2014, 19:35 GMT
The intended behaviour should be either:
A - become a spectator in the new game without any company
B - client list should list me as playing in company 1

Loading...