OpenTTD

Tasklist

FS#5959 - Trains fail to load cargo from the station, 1.4.0-RC1

Attached to Project: OpenTTD
Opened by Helge Hafting (hafting) - Monday, 31 March 2014, 12:46 GMT
Last edited by andythenorth (andythenorth) - Friday, 01 September 2017, 10:24 GMT
Type Bug
Category Vehicles → Cargodist
Status Closed
Assigned To No-one
Operating System Linux
Severity Medium
Priority Normal
Reported Version other
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Openttd 1.4 RC1
FIRS industry
FISH 0.9.2
GRVTS 1.4 32bpp
av8
opengfx+ trains 2014-01-07 (FIRS compatible and nice looking 32bpp)

With FIRS, it makes sense to deliver several cargoes simultaneously to some industries. So I collect raw materials at "Melenga Plantasje", and have trains bringing properly mixed cargo to the steel & aluminium industries.

This approach worked well with various betas - but in RC1 the trains suddenly refuse some cargoes. At "Melenga Plantasje", train7 sits waiting for chemicals, bauxite and scrap metal. There were no problems loading bauxite & chemicals. Then I added a line bringing in scrap metal, for further production boosts. There is now plenty of scrap metal, but the train won't load any. Strangely, train7 will load scrap metal when the scrap metal train comes in and unloads. But it will not pick up any of the scrap metal already lying around at the station.

Train1 is rolling into the station, because I want it to load some scrap metal too. But it is not happening, and so this game is ruined. I did not have such problems with my beta4 and beta5 games. The savefile is attached.

I use an unreleased version of opengfx trains, in order to get nice looking 32bpp trains. (And FIRS compatible cargo handling) The grf is too big to attach, but can be found at http://www.aitel.hist.no/~helgehaf/openttd/ogfx-trains.grf
This task depends upon

Closed by  andythenorth (andythenorth)
Friday, 01 September 2017, 10:24 GMT
Reason for closing:  Won't fix
Additional comments about closing:  As per my 23rd August 2017 comment: may already be fixed, no similar reports. Didn't try to repro in 1.7.1, Frosch already repro-ed the original report in 1.4 or so, and repro in 1.7.1 requires downloading grfs not on bananas, TMWFTLB.

Flyspray clean up, no path forward for this one, closing. Thanks for the report.
Comment by frosch (frosch) - Thursday, 01 May 2014, 13:33 GMT
Apparantly the train forgot to reserve cargo for loading. (CDist is set to manual)
The situation fixes itself when new cargo arrives for loading somewhen later.
Comment by andythenorth (andythenorth) - Wednesday, 23 August 2017, 07:07 GMT
There were a bunch of station reservation fixes committed by fonsinchen in June and October 2014, this behaviour may have been closed by one ore more of those.
https://git.openttd.org/?p=trunk.git;a=commit;h=1b8186ea8e3e3e549f782430f03ef313f180f617

No other reports of this, and a tar pit to reproduce and diagnose.

Loading...