OpenTTD

Tasklist

FS#5893 - Do not expire airports (was: Feature removal request)

Attached to Project: OpenTTD
Opened by Simon Smith (Simons_Mith) - Saturday, 01 February 2014, 23:08 GMT
Last edited by frosch (frosch) - Sunday, 07 September 2014, 16:09 GMT
Type Feature Request
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version Version?
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Airport expiry applies to the small airfield only, AFAICS. Why do we bother with expiry just for this one case? The airport menu is not in the least crowded. What do we gain from having the ability to make airports expire?
This task depends upon

Closed by  frosch (frosch)
Sunday, 07 September 2014, 16:09 GMT
Reason for closing:  Implemented
Additional comments about closing:  years ago. There is an "never expire airports" advanced setting
Comment by Ingo von Borstel (planetmaker) - Sunday, 02 February 2014, 20:08 GMT
Use an airport NewGRF which changes the expiry date. E.g. OpenGFX+ Airports allows to remove the expiry date.
Comment by Simon Smith (Simons_Mith) - Monday, 03 February 2014, 00:18 GMT
You've completely missed my point!
Comment by Ingo von Borstel (planetmaker) - Monday, 03 February 2014, 07:21 GMT
We do not change the stats of the default game items in this case for the same reason we don't do that in all other cases: NewGRFs, scenarios and game scripts can rely on the these to remain unchanged. Why should the first airport not expire? Or why not introduce all airports at all times? The default vehicle lists are also not so crowded as to force expire any of them - why not change those dates? Or add further ones earlier on? All the same kind of question.
Comment by Vid the Kid (vtk) - Wednesday, 12 February 2014, 18:59 GMT
I agree that, ideally, airports should not expire. This was a curious and sometimes inconvenient feature of the original game. Vehicle expiry is explained as the manufacturer simply no longer produces that vehicle, but with airports that concept doesn't really hold up. Companies and/or governments build airports in whatever size fits their expected needs. The only explanation for unavailability of smaller airports is some kind of government standards prescribing a minimum size, perhaps among other safety features; I'm not aware of any governments imposing such size minimums as to make the construction of new small airports illegal.

However, to address this as a change to the game core would mean it doesn't make sense for airport expiry to even be possible in the first place. Even if it weren't the default behavior, it makes some sense to have at least the possibility of airports to become available/unavailable based on the date like so many other constructable objects in the game. Some players might want that functionality, possibly involving airports that aren't original to TTD. Perhaps Simon's original complaint would be more reasonable if it were made in reference to the baseset, rather than the game core.

If we were designing the game from scratch in 1993, I would argue that airports that ship with the game should not become unavailable over time. But this isn't the conclusion Chris Sawyer reached. So now we have the TTD baseset, and its free-art clone OpenGFX, which make use of airport expiry. As planetmaker pointed out, other game components tend to rely on the stats of objects in the baseset, so changing those would be inadvisable.

At the root of the problem is a game design decision made over 20 years ago. Changing this decision now would be mildly disruptive; changing the game core to make the original decision impossible would surely introduce dozens of new bugs. Fortunately, players are free to override things in the baseset with NewGRFs. This is exactly what NewGRFs are for.

Loading...