OpenTTD

Tasklist

FS#5880 - Town and city growth settings ineffective/broken

Attached to Project: OpenTTD
Opened by Simon Smith (Simons_Mith) - Monday, 27 January 2014, 22:58 GMT
Last edited by frosch (frosch) - Tuesday, 28 January 2014, 19:15 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version 1.4.0-beta3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

While working on tweaking english.txt I wanted to test and document current growth behaviour, and I came across this town growth bug.

Map settings used were Temperate mountainous 2048x2048, (although I'd expect proportional behaviour on any combination of map settings), one year's growth (or 13 months pro-rated if I wasn't paying attention), no company building of any kind

Growth rate: Low
Cities: None
World pop: 193081->215204, 11.5% growth
Largest town: 1084->1084, 0% growth


Seed: 12345678
Growth rate: Low
Cities: 1 in 1
World pop: 853351->935996, 9.6% growth
Largest city: 3612->4025, 11.4% growth

Seed: 12345678
Growth rate: Very High
Cities: 1 in 1
World pop: 853351->936369, 9.7% growth
Largest city: 3612->4037, 11.8% growth

Allowing for random variation from one game to another, Low and Very High town growth rates are indistinguishable from one another, and cities, if they do grow faster, do so at other towns' expense, and it seems they cause a net slowdown in population growth overall.


Sustained growth of ~10% a year is bloody impressive. I'd suggest 'Very High' be changed to current behaviour, and lower growth rates be done with a 50%, 67%, 75%... chance of ignoring a growth instruction, thus giving growth rates of 1/2, 1/3, 1/4... of the maximum. It would work in-game a bit like freight multipliers. Is it possible a really high value might help slow shrinkage down with daylength patches...?

I'd also suggest (if there's no code in there ATM) that town growth is also slowed by recessions, by doubling the configured growth divider.

Am I right that cities grow faster than non-cities by getting first dips on the computer's 'grow town' tick events?
This task depends upon

Closed by  frosch (frosch)
Tuesday, 28 January 2014, 19:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  at least I see nothing wrong
Comment by Simon Smith (Simons_Mith) - Monday, 27 January 2014, 23:11 GMT
Probably relates to 5827
Comment by Simon Smith (Simons_Mith) - Monday, 27 January 2014, 23:22 GMT
]Real world annual growth rates vary from a little less than zero to 4%+]
Comment by frosch (frosch) - Tuesday, 28 January 2014, 19:15 GMT
FS#5827 is related the game scripts.

Town growth is very little without company constructions.
Without any companies a town has 1/12 chance to grow at all during a month. So measuring over one year is pretty pointless. So the 11% you measured may refer to a single house?

Town growth is not expressed by population, but my number of houses.

The population per house depends highly on NewGRF and game year.

Each town growth setting doubles the growth speed. Cities are one category higher (i.e. double growth compared to non-cities).
Comment by Simon Smith (Simons_Mith) - Tuesday, 28 January 2014, 20:30 GMT
> Town growth is very little without company constructions.

Agreed, but it's not /zero/ unless town growth is set to none. In this case I intentionally didn't build anything so as to get the base rates!

> Without any companies a town has 1/12 chance to grow at all during a month. So measuring over one year is pretty pointless. So the 11% you measured may refer to a single house?

No, I monitored an entire map of about 340 towns, and I also particularly watched the single most populous town, which changed a few tiles and maybe grew by 1 or 2.

Over the map as a whole, as I said, you get about 11% growth. For individual towns, if a building tile is replaced with a park tile, that town's population may even drop a little, so from town to town you see much more variation than the world population. But world population always creeps upwards, so growth is always happening somewhere. Town pop. /is/ proportional to how many tiles it has, even if the relation isn't perfect, but across an entire 2Kx2K map I believe I'm getting a decent statistical picture. But if town growth across a map is the same regardless of whether growth settings are Low or Very High then I'd assume something's screwy, and besides, a growth rate of 11% per annum /before/ a company starts shipping extra passengers or goods is a hell of a big base level.

If town growth settings 'Low' through 'Very High' only apply to towns that a company is developing, then please can you confirm that, and I'll update the tooltip help text accordingly. That's what I was working on when I noticed this anomaly.
Comment by Simon Smith (Simons_Mith) - Tuesday, 28 January 2014, 20:33 GMT
Can you look at this again, please? I still need an answer so I can update the tooltip accordingly.
Comment by frosch (frosch) - Monday, 03 February 2014, 18:05 GMT
The growth rate applies to all towns, independent of service.

Loading...