OpenTTD

Tasklist

FS#5777 - TRIGGER_VEHICLE_SERVICE is not triggered for wagons

Attached to Project: OpenTTD
Opened by George (George) - Friday, 04 October 2013, 10:48 GMT
Last edited by frosch (frosch) - Wednesday, 13 November 2013, 14:35 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System Windows
Severity High
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
  • George (George) (2013-10-05)
Private No

Details

R25810

the bug can be tested with xUSSR wagon 15-886. When entering depot it should be reversed with 50% probability, but it never happen.

random_switch (FEAT_TRAINS, SELF, tanker_15_886_sprites_2, bitmask(TRIGGER_VEHICLE_SERVICE))
{
independent: tanker_15_886_sprites_l;
independent: tanker_15_886_sprites_r;
1: tanker_15_886_sprites_l;
1: tanker_15_886_sprites_r;
}

This task depends upon

Closed by  frosch (frosch)
Wednesday, 13 November 2013, 14:35 GMT
Reason for closing:  Bug in NewGRF
Comment by frosch (frosch) - Wednesday, 13 November 2013, 14:32 GMT
Wagons are triggered for rerandomisation, but the NewGRF does not rerandomise any bits.

I believe this is caused by the "short_vehicle" template, which chains to "dummy_sprites" if the vehicle is in a depot. So, the random switch is not reached.

Loading...