OpenTTD

Tasklist

FS#5590 - liveries list is not complete

Attached to Project: OpenTTD
Opened by George (George) - Friday, 07 June 2013, 15:38 GMT
Last edited by frosch (frosch) - Saturday, 08 June 2013, 12:25 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
  • George (George) (2013-06-07)
  • Vladimir Guryanov (Wowanxm) (2013-06-07)
Private No

Details

R25306

As it seen at the screen shot, wagons have many liveries, which are the same. But when they are together, the list of liveries contains only first liveries, which are the same. liveries after the first diff are not represented, even when they are the same

This task depends upon

Closed by  frosch (frosch)
Saturday, 08 June 2013, 12:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:  of FS#3764
Comment by Ingo von Borstel (planetmaker) - Friday, 07 June 2013, 22:44 GMT
Subcargos generally are only considered the same when their ID (number) matches AND their string matches. That's by design. If you want your wagons to agree on that, make cargo subtypes match in ID and naming.

Loading...