OpenTTD

Tasklist

FS#5350 - Road vehicle passenger transportation over 1 tile seems to be a good way to earn money...

Attached to Project: OpenTTD
Opened by Tobias Frei (ToBeFree) - Thursday, 01 November 2012, 20:02 GMT
Last edited by frosch (frosch) - Saturday, 11 March 2017, 23:10 GMT
Type Feature Request
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version 1.2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Building stations like in the screenshot seems to be quite profitable - and imho, it should not. I am not sure if this is a bug or a feature request. :-/

The savegame is 6,6MB big; I hope the screenshot is enough... Should be quite easy to reproduce.^^
This task depends upon

Closed by  frosch (frosch)
Saturday, 11 March 2017, 23:10 GMT
Reason for closing:  Won't implement
Comment by frosch (frosch) - Thursday, 01 November 2012, 23:42 GMT
This is known as "station walking". Lower "max station spread" in advanced settings to reduce the effect.
Comment by Tobias Frei (ToBeFree) - Friday, 02 November 2012, 15:41 GMT
I assume "to reduce the effect" means "to make abusing this a bit harder" in this case. I would prefer a real solution, if possible :-/
Comment by Thijs Marinussen (Yexo) - Friday, 02 November 2012, 18:48 GMT
There is a very good solution available:
1) Don't use it yourself
2) Only play on servers that disallow these things and have 1 or more people in place to enforce the rules.
Comment by Tobias Frei (ToBeFree) - Friday, 02 November 2012, 19:36 GMT
I almost expected an answer like this. :-/

However, you could suggest that solution for every bug which allows a player to get money by abusing something in OpenTTD. I wonder if there is an alternative to "accepting the bug and kicking everyone who uses it"...
Comment by Alberth (Alberth) - Friday, 09 November 2012, 13:46 GMT
We have no problems with a better solution, except we don't know one.
Comment by Tobias Frei (ToBeFree) - Friday, 09 November 2012, 13:49 GMT
One idea might be adding something like a "minimum transport distance" - or what about increasing the profit for long routes and decreasing it for short ones? :-)
Comment by frosch (frosch) - Friday, 09 November 2012, 14:33 GMT
Both is already the case.

The reason you can cheat with large station spread is that the cargo is always considered to be a the tile with the station sign.
So, for the profit the distance of the station signs matters, not where the vehicles are. Travel distances within a station are free.

Now, one might suggest to use the position of the vehicle, or even every single wagon for the loading position and thus distances. But this already breaks when considering train reversal.

Now, one might suggest to make train reversing take time... but this only goes further down the road of non-sense.

This is about the essential game mechanics of OpenTTD and the different distance scales used. I doubt there is any sane way to "fix" this.

Loading...