OpenTTD

Tasklist

FS#5031 - Road Vehicles go through each other.

Attached to Project: OpenTTD
Opened by Sam (Geekysmackthat) - Monday, 30 January 2012, 10:59 GMT
Last edited by Remko Bijker (Rubidium) - Monday, 30 January 2012, 18:30 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.1.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi
I am using openttd 1.1.5 64 bit on 2 different pcs (one running 7 home premium (SP1) the other running 7 professional (SP1) both 64 bit) and I noticed a bug involving road vehicles and drive through stops. It seems that when road vehicles que up around a corner, they go through each other blocking the traffic. The new GRFs i was using have been attached, although I was using the default road vehicle set apart from trams. The save file was saved right above the station where the glitch occurs, the glitch only occurs when there is a farely large que for the station.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 30 January 2012, 18:30 GMT
Reason for closing:  Won't fix
Additional comments about closing:  It's gridlock prevention/a feature.
Comment by Remko Bijker (Rubidium) - Monday, 30 January 2012, 18:30 GMT
What you are seeing here are the effects of total gridlock prevention. If a vehice is waiting behind a stationary vehice for a too long time it will simply drive through that vehicle making it possible to clear up a deadlock/gridlock.
Comment by Sam (Geekysmackthat) - Tuesday, 31 January 2012, 09:54 GMT
So it is not a bug?
Comment by Remko Bijker (Rubidium) - Wednesday, 01 February 2012, 06:32 GMT
From some points of views it might be considered a bug, however having unsolveable deadlocks is a more serious bug. Given these can't be fixed both we have to make a decision which bug to leave. Sadly enough (for you) that means this bug stays, but on the other hand in multiplayer someone can't create a complete gridlock.

Loading...