OpenTTD

Tasklist

FS#4980 - Roads in NewGRFs don't change

Attached to Project: OpenTTD
Opened by wilson (wilson) - Sunday, 15 January 2012, 23:00 GMT
Last edited by Thijs Marinussen (Yexo) - Monday, 16 January 2012, 13:14 GMT
Type Bug
Category NewGRF
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.2.0-beta2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Roads don't change over time in NewGRFs where they are supposed to, like in TTRS or NA Roads set.

(Not sure if it's unknown, the bug is in 1.1.4 too.)
This task depends upon

Closed by  Thijs Marinussen (Yexo)
Monday, 16 January 2012, 13:14 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Those NewGRFs abuse the specs to display different graphics for roads in different years. This is not supported, although it does work if you save and load your game. In multiplayer games it won't work at all.
Comment by PaulC (PaulC) - Monday, 16 January 2012, 02:36 GMT
See the readme files for those grfs. You need to save your game and reload it for the roads to change over, it's not possible any other way. It's not a bug in OTTD but a limitation of what NewGRFs are capable of.

Loading...