OpenTTD

Tasklist

FS#4947 - More zoom-out levels

Attached to Project: OpenTTD
Opened by Kévin Guilloy (felixzero) - Wednesday, 04 January 2012, 02:17 GMT
Last edited by andythenorth (andythenorth) - Thursday, 31 August 2017, 20:59 GMT
Type Feature Request
Category Interface
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version 1.2.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
  • NG (NG) (2012-01-24)
Private No

Details

Hello OpenTTD developers,
OpenTTD is definitely a nice game, but I would be cool to be able to play nicely on very large maps (2048*2048). The problem is that, we get very easily lost and it is very difficult to have a global view of the map.
What would be very good, would be to have extra zoom-out levels (for example, x0.5 and x0.25 from now), just like the new zoom-in levels added to the 1.2.0 beta.
Regards,
Kévin Guilloy
This task depends upon

Closed by  andythenorth (andythenorth)
Thursday, 31 August 2017, 20:59 GMT
Reason for closing:  Won't implement
Additional comments about closing:  There are enough zoom levels provided.

Flyspray clean up, closing, thanks.
Comment by Patric Stout (TrueBrain) - Wednesday, 04 January 2012, 13:38 GMT
At those zoomlevels, you are better off using the smallmap. Tiles become pixels on your screen, and you won't really be able to tell the green pixels from the dark green next to it.

So for that we have the smallmap. It shows in much better detail how your map looks, in a very zoomed-out fashion.
Comment by Kévin Guilloy (felixzero) - Wednesday, 04 January 2012, 15:23 GMT
The problem is that the switch from the minimap to the big map is not very convenient. From the big map, you have to go in a menu to "zoom-out". And then to "zoom-in" close the newly opened window.
An idea could be to display the minimap fullscreen while zooming out. And going back to the normal map while zooming in.
Comment by NG (NG) - Friday, 06 January 2012, 03:31 GMT Comment by Kévin Guilloy (felixzero) - Friday, 06 January 2012, 04:30 GMT
Indeed...
I just installed this patch. It works very well.

Loading...