OpenTTD

Tasklist

FS#441 - Transparent stuff

Attached to Project: OpenTTD
Opened by Anonymous Submitter - Friday, 08 December 2006, 18:35 GMT
Last edited by Darkvater (Darkvater) - Saturday, 09 December 2006, 00:57 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Very Low
Priority Low
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

MiniIn - 7430
Ok, this one is hard to explain and I can't take a screenshot of it. I get the feeling it's actually a windows bug, but I'll let you decide, and I can't test on nix anyway.

Setup:
I've got my browser up (Opera 9) and I'm watching NasaTV - http://www.nasa.gov/multimedia/nasatv/live_tv.html
I load up OTTD fullscreen over my browser (NOT minimised) and start playing.
Except that EVERYTHING that's black is transparent. But ONLY where is "over" NasaTv that is running in the background. Thus I can watch NasaTv through OTTD. :-D

If I minimise the browser, the transparent stuff all becomes black again.
The really funny thing is that "on top" of the browser I can have a directory, or something, but the transparency still shows through this.

In-game screenshots and even windows screenshots don't actually show this phenomena :-( .


Note: NasaTV uses windows media player, not flash. Doesn't happen with google vid (flash based).
As I said, I suspect it's windows and it doesn't really need to be fixed, it's just "weird behaviour" I thought you might be interested in. :)

Moriarty
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 09 March 2007, 03:35 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Or rather, not our bug; it is actually a Windows 'bug'. We cannot do anything about it.
Comment by Darkvater (Darkvater) - Saturday, 09 December 2006, 00:56 GMT
It has to do with video overlay. Seems like it's not exactly friends with GDI or we are doing something wrong

Loading...