OpenTTD

Tasklist

FS#4371 - assert IsValidConsoleColour(colour_code)

Attached to Project: OpenTTD
Opened by Nathanael Rebsch (dihedral) - Monday, 03 January 2011, 01:55 GMT
Last edited by Remko Bijker (Rubidium) - Monday, 03 January 2011, 20:54 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

reproduce with dedicated console command 'say hi'

Error: Assertion failed at line 133 of /home/nathanael/Development/openttd/src/console.cpp: IsValidConsoleColour(colour_code)

(gdb) bt
#0 0x00007ffff653ba75 in raise () from /lib/libc.so.6
#1 0x00007ffff653f5c0 in abort () from /lib/libc.so.6
#2 0x000000000069bca5 in error(char const*, ...) ()
#3 0x0000000000584894 in IConsolePrintF(ConsoleColour, char const*, ...) ()
#4 0x000000000062bb6d in NetworkTextMessage(NetworkAction, ConsoleColour, bool, char const*, char const*, long long) ()
#5 0x00000000006408e6 in NetworkServerSendChat(NetworkAction, DestType, int, char const*, ClientID, long long, bool) ()
#6 0x0000000000581bc7 in ConSay(unsigned char, char**) ()
#7 0x0000000000584ec2 in IConsoleCmdExec(char const*) ()
#8 0x00000000007cdc65 in VideoDriver_Dedicated::MainLoop() ()
#9 0x000000000069dfa0 in ttd_main(int, char**) ()
#10 0x00007ffff6526c4d in __libc_start_main () from /lib/libc.so.6
#11 0x00000000004b7c49 in _start ()
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 03 January 2011, 20:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r21707
Comment by Zdeněk Sojka (SmatZ) - Monday, 03 January 2011, 01:57 GMT
Probably caused by:
network_server.cpp:1145 NetworkTextMessage(action, (ConsoleColour)GetDrawStringCompanyColour(ci->client_playas), false, ci->client_name, msg, data);
where it casts "something" to ConsoleColour

Loading...