OpenTTD

Tasklist

FS#4165 - Dragging articulated vehicles in the depot is incomplete

Attached to Project: OpenTTD
Opened by Johannes E. Krause (Eddi) - Saturday, 16 October 2010, 15:23 GMT
Last edited by Ingo von Borstel (planetmaker) - Saturday, 10 May 2014, 23:12 GMT
Type Feature Request
Category Interface
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

when dragging an articulated vehicle in the depot, the initial selection shows the full length of the vehicle.

but when moving the cursor, it only takes on the first section of the vehicle, and inserting it into other trains also shows only a placeholder for the first vehicle.

see with attached test grf providing a 3-part-articulated wagon, the mouse cursor turns invisible, when dragging the wagon in the depot.
This task depends upon

Closed by  Ingo von Borstel (planetmaker)
Saturday, 10 May 2014, 23:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r24352
Comment by Zdeněk Sojka (SmatZ) - Sunday, 17 October 2010, 12:26 GMT
I don't think it's good to have that large mouse cursor. Also this is consistent with dragging of multiheaded engines - always only the first part is shown.
Comment by Zdeněk Sojka (SmatZ) - Sunday, 17 October 2010, 15:18 GMT
  • Field changed: Type (Bug → Feature Request)
Currently by design, changing to Feature request
Comment by Johannes E. Krause (Eddi) - Monday, 18 October 2010, 14:04 GMT
I'm just saying it's inconsistent with the rest of the game. E.g in the train details and elsewhere, articulated vehicles are treated as one entity.

Loading...