OpenTTD

Tasklist

FS#415 - Multiplayer Desync Error... (More)

Attached to Project: OpenTTD
Opened by Anonymous Submitter - Tuesday, 21 November 2006, 10:23 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 0.4.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

Back again, I post a while ago about a multiplayer desync error...

"Not sure where or how to report this but here goes, stepbrother and I have tried to play a multiplayer game with version 047 but failed, stepbrother kept getting disconnected from the game due to a desync error, he reconnected and picked up where he left off but got disconnected again after about 2 minutes. We upgraded to version 048, but this time he hosted the game (he has a faster system) and I connected, played for about 5 - 10 minutes then I got disconnected due to a desync error, same deal, I reconnected and picked up from where I left off, but again after about 2 minutes I got disconnected. Summary, the first disconnect happens after about 5 - 10 minutes of play, then every 1 - 2 minutes after you reconnect to the game. I have tried hosting and so has stepbrother, but the one that connects gets the desync error.

Hope you can understand this, don't understand why its happening as we have played multiplayer before with version 047 without problems, but that was before stepbrother upgraded his system. If there are any files you need let me know... :)"

Ok, well I have some more information that I hope will help, this time we tried again to play but I setup one system to be a server and myself and brother connected to it, but the same thing happened after about 5 minutes into the game, brother got disconnected by a "desync error". I started to think about what could be causing this, when we played before we were connected by a 'port switch' but this time we are not, I am connected to a 'port switch' which is connected to a 'router'. He is connected to a 'port switch' which is connected to the same 'router', I thought this maybe the cause of the problems.

But its not, we started a new game, I was playing on my Laptop while brother was on my system, this time we got a "connection failed error" first after about 5 minutes, he reconnected to the game but then after a minute or so he got a "desync error", at that point we gave up trying.

Like I said before, I don't understand why this is happening now, we have played multiplayer in the past without problems.

Glen Grainger.
nightcrawler at westnet dot com dot au.
This task depends upon

Closed by  Darkvater (Darkvater)
Sunday, 31 December 2006, 03:23 GMT
Reason for closing:  Deferred
Additional comments about closing:  Sorry all we can do about general desync errors is take notice of them and wait there is fix somewhere sometime fount.

Loading...