OpenTTD

Tasklist

FS#3956 - multi track building changes to track converter

Attached to Project: OpenTTD
Opened by Robbie Kleij (mdbobbo) - Friday, 16 July 2010, 22:16 GMT
Last edited by Remko Bijker (Rubidium) - Tuesday, 20 July 2010, 17:00 GMT
Type Bug
Category Build system
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version 1.0.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

when building more than one section of train tracks the build tool reverts to the track converter build tool.

when attempting to build a bridge of any length the same track converter tool appears as the default tool after the attempted build and no bridge build choice is avalible ( also the bridge building choice window does not open)

when holding down the CTRL key while building a bridge a bridge is built (no build window but it maybe only one bridge is avalible due to game years) ( not sure of that )

when building one train track section only the track converter tool does not become the default and a second section can be built

I have had in previous versions the same errors where the track converter tool became the default on building multi trai track sections, but this version seems to go one step further by making bridges impossible to build.

Robbie Kleij IT professional and freeware broker www.treezone.co.nz
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 20 July 2010, 17:00 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Bug caused by external applications sending OpenTTD key presses.
Comment by Remko Bijker (Rubidium) - Friday, 16 July 2010, 22:44 GMT
I've got the serious suspicion that you are pressing some keys on the keyboard or that something else causes those keyboard events to be sent. For example "c" is the shortcut for the track converter, so if that gets pressed it will (automatically) go the that mode. Some experimenting confirms that pressing CTRL while building a bridge and then pressing "c" does not open the track converter, which reinforces my suspicion that it is related to key presses.
If you are not pressing the keys there might be something else that causes these events to be caused. Like someone playing with software to remotely take over (parts) of your computer.
Might it be that releasing the mouse triggers something to send the "c" key pressed? Could possibly be tested by creating a sign and trying to change the name and, after clicking on the input box, clicking on the letters in the on screen keyboard window. If the "c" gets added each time, then that's the culprit. If the "c" gets added without doing something, then at least you know something tells OpenTTD the "c" has been pressed.

I would say it is *highly* unlikely that it is a bug in OpenTTD given the at least 60 thousand downloads of OpenTTD without a single mention and the fact that there are (at this moment) 100+ people playing OpenTTD on a 1.0.2 server.
Comment by Robbie Kleij (mdbobbo) - Friday, 16 July 2010, 23:08 GMT
I tried what you have suggested and yes when I press the "C" key I do get the track converter tool and yet when I make a track more then one section the track converter tool takes the place of the track laying tool I've just used being any one of the track laying tools that are avalible even when opening a new map from a fresh start (without touching my keyboard) the track converter tool replaces the track laying tool.

I'm sure you understand I a 57 year old It professional but mention it anyhow.

thi error as I mentioined before has been plauging Openttd for the last four or so versions but never before has it internfeared with making a bridge so I just put up with it until now
Comment by Remko Bijker (Rubidium) - Friday, 16 July 2010, 23:26 GMT
Which four versions?
Have you tried the on-screen-keyboard thing? If so, what are the results?
Is the rail building tool already opened when you start a new game?
What exact version of Windows are you using?
Comment by Robbie Kleij (mdbobbo) - Saturday, 17 July 2010, 05:49 GMT
I think Ill try uninstall the version I've got now an dreinstling it as I've had it upgraded since openttd became updatable and I've added some of the TTDX patch addon in there that might repair it.


No I have not tried the on screen keyboard to se if that's effecting it.

I running windows vista home premium 64 bit although the openttd has worked without this error at some stage in the past.

just leave it with me for a while and I'll tell you the result when it's been freshly installed.

some notes:

I've been trying to sort out the GRF's into manageable sections as they can not be loaded all at once,

I'll sort out so that the only the openTTD Grf's are used and a fresh install will do it the world of good since I've had it so long updating every time.

thank yo for your feed back anyhow.

till next place

Robbie Kleij

Comment by Johannes E. Krause (Eddi) - Saturday, 17 July 2010, 23:46 GMT
I suspect this is something outside of OpenTTD, in the mouse handling after a drag&drop operation. Maybe a "Gestures" feature of some sort. Try searching for this in your system settings, and see if disabling it helps.
Comment by Robbie Kleij (mdbobbo) - Tuesday, 20 July 2010, 08:05 GMT
I completely uninstalled openTTD and reinstalled with ll new grifs
the new instalation has the same errors

I noticed that when left clicking the openttd screen ( with left click scrolling at the default off setting) the "track converter tool" is also toggles as is shown in the attached pictures then when the openttd screen is draged again (same settings) the "track converter tool" is again toggles off.
I can conclude from this that the toggling of the "track converter tool" is something to do with left mouse dragging weather building a railway track or not.
I also note that when biulding a piece of road way the openttd windows centers (somewhat) to the middle of the screen where the roadway is ending on construction, the track converter at this time is not employed but erronious movement is still there.

For these test I have loaded the default setting so that no other setting would interfear with the test.

LASTLY: the rail build icon at the top of the screen now show correctly on re-installation as previously the reail build icon was displaying a BAR ACROSS THE ICON. shown in the two small captures
Comment by Robbie Kleij (mdbobbo) - Tuesday, 20 July 2010, 08:27 GMT
problem soluved .... [=^_*=]

there is a bug in conjuction with either the onscreen keyboard making the keyboard use keys in the hover setting

there is a bug in conjuctin with Crazybrowser mouse navigation setting.
when these two are both switched off the Openttd "track converter tool" soes not toggle on and off when making movements with the game.

will make some further testing and write a report in the next few day

Robbie Kleij.

Thank you for all your help and suggestions to find this anomaly.

Loading...