OpenTTD

Tasklist

FS#3831 - Servicing of trains doesn't work if the track to the debug is not directly enough

Attached to Project: OpenTTD
Opened by Peter Henschel (Progman) - Tuesday, 11 May 2010, 18:30 GMT
Last edited by Remko Bijker (Rubidium) - Thursday, 13 May 2010, 15:27 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r19780

I have some problems in auto servicing (and in resulting auto replacing) trains, which never enters a depot even if they could. If you check the attached game you see a sign "Line NW". On this line are a lot of steam trains which aren't replaced yet since they never entered a depot. As you see they have several tries to actually join a depot (like all the other trains on the other lines), but they never do. It looks like that the way how the tracks are build refuse the train to enter the depot as the trains aren't on a straight track when they decide to enter a depot.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Thursday, 13 May 2010, 15:27 GMT
Reason for closing:  Not a bug
Comment by Peter Henschel (Progman) - Wednesday, 12 May 2010, 11:55 GMT
The attached game shows the problem as well (same game). The SH40 trains do not enter the depot for maintenance, but the T.I.M trains on the same line do.
Comment by Remko Bijker (Rubidium) - Thursday, 13 May 2010, 15:27 GMT
The SH40 route isn't the same as the T.I.M. route. Or at least not for the auto servicing.

Auto servicing only happens when a train is within a given amount of pathfinder penalties (you can configure this number). The "approach" for the T.I.M. is straight, whereas for the SH40 you have an S-turn. This S turn is more expensive in pathfinder penalties than just a single turn; changing the route so it doesn't have the S turn makes the SH40 trains go into the depot as they 'should'.

Furthermore red signals have a penalty worth some 10 straight tiles and path signals are by default red and as such shortens the distance your depot needs to be from the main track significantly.

Finally, we won't change the current behaviour; you can increase the amount of penalty you want your trains to search for, but bear in mind that that might make trains lost when they're finding depots on branches the train isn't supposed to go on. It will also be more computationally expensive, i.e. OpenTTD will run slower, however you can configure it so it effectively tries to search the whole map for a depot.

Loading...