OpenTTD

Tasklist

FS#3619 - Desync in multiplayer

Attached to Project: OpenTTD
Opened by Marcel Sondaar (Combuster) - Saturday, 13 February 2010, 19:26 GMT
Last edited by Remko Bijker (Rubidium) - Monday, 15 February 2010, 23:56 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version trunk
Due in Version 1.0.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Net sync error appears between 5 seconds and one minute of connecting a game.

To reproduce:
Start server from save game (attached)
Start a client and connect to the server (either of joining the company and spectating will do)
Wait.
(reproducability: always)

Version used is r19068
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 15 February 2010, 23:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r19141
Comment by Marcel Sondaar (Combuster) - Saturday, 13 February 2010, 21:52 GMT
Minor correction: Reproducability rates lie somewhere around 85%. Repeated attempts to join this game eventually succeed.
Comment by frosch (frosch) - Saturday, 13 February 2010, 23:07 GMT
The desync is caused by trains choosing different platforms at the dropoff station. It is not specific to a certain train or date, but seems to depend on join date. The time until desync varies from few days to few months.

Enabling the yapf cache debugging triggers shortly after loading the game in singleplayer (actually not at the dropoff station). However the stuff in dbg_helper is totally broken :/
Comment by Ingo von Borstel (planetmaker) - Sunday, 14 February 2010, 11:35 GMT
Just a short remark on the savegame: the big drop station is not one station, but 6 separate ones interwoven as much as possible where tracks alternate every station track of it.

EDIT and disabling the yapf cache on both, server and client seems to let me connect without desync (frosch's patch https://devs.openttd.org/~frosch/diffs/disableyapfcache.diff )
EDIT2: Note also the trains' orders: the main drop station is not part of the orders.

Loading...