OpenTTD

Tasklist

FS#3384 - (Articulated?) Road vehicles don't use all available stops in r18523

Attached to Project: OpenTTD
Opened by David (edeca) - Friday, 18 December 2009, 15:08 GMT
Last edited by Remko Bijker (Rubidium) - Friday, 18 December 2009, 21:36 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am using the nightly 18523 and road vehicles do not appear to use all stops. I have tried all sorts of one way, rebuilding the stop etc. A savegame is available at http://edeca.net/temp/openttd/example.sav (>8MB)

It appears to be articulated vehicles that cause this. A smaller map that also seems to reproduce the problem is attached. The vehicles can be sent to the depot and then started again to see them all head for the nearest station.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 18 December 2009, 21:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r18531
Comment by David (edeca) - Friday, 18 December 2009, 15:42 GMT
Attached is a savegame that only uses eGRVTS (for the articulated vehicles). Should be easier for people to open.
Comment by David (edeca) - Friday, 18 December 2009, 15:43 GMT
Oops, the correct savegame.
Comment by Remko Bijker (Rubidium) - Friday, 18 December 2009, 15:46 GMT
There is a pathfinder penalty for the occupiedness of the roadstop. In your case you want that do be higher, but in other cases it should be lower. Anyhow, a stop will only be occupied when there's a vehicle actually in it, so you should try to avoid long entry lines because that means lots of vehicles see it as empty and all follow eachother.

Anyhow, the problem is 'fixed' by a higher occupiedness penalty for the road stop. Then reducing the entry length will help; delaying the choice of which entry to take makes it possible for the pathfinder to make a better decision.

Loading...