OpenTTD

Tasklist

FS#2968 - Cargo accaptence area broken

Attached to Project: OpenTTD
Opened by Expresso (Expresso) - Sunday, 07 June 2009, 19:25 GMT
Last edited by Zdeněk Sojka (SmatZ) - Monday, 08 June 2009, 00:26 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

For figuring out what cargo is accepted to a station, a station defines 4 edges. These are the upper, lower, left and right edges. These are found by searching for the station tiles which are most in the respective direction.

This allows for cheating in the following way:
one could position 4 station squares beloning to the same station around a town, but as far away as possible from eachother. This results in the entire town falling in the area where cargo can be dropped off.

NOTE: this bug is only applicable to cargo being dropped off at the station by a vehicle, not cargo delivered to a station by the town.

See the attached savegame for an example of this bug in action.
This task depends upon

Closed by  Zdeněk Sojka (SmatZ)
Monday, 08 June 2009, 00:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is how things work.

Loading...