OpenTTD

Tasklist

FS#279 - Changed station name missed some characters

Attached to Project: OpenTTD
Opened by pven (pven) - Wednesday, 16 August 2006, 18:57 GMT
Last edited by KUDr (KUDr) - Wednesday, 15 November 2006, 13:40 GMT
Type Bug
Category Core
Status Closed
Assigned To KUDr (KUDr)
Operating System All
Severity Low
Priority Normal
Reported Version 0.4.8
Due in Version 0.5.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If the PC is (very) slow, and you try to change a station-name, and enter the new station name at normal speed (80-100 pm) the name will miss some characters.

example:
I type "Amsterdam Centraal Station".
I see on screen something like "Amstrdm CetralSttin"

This task depends upon

Closed by  Darkvater (Darkvater)
Wednesday, 15 November 2006, 19:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  r7153
Comment by Loïc GUILLOUX (glx) - Thursday, 17 August 2006, 23:54 GMT
Just type at a slower speed :)

BTW, what is your OS?
Comment by pven (pven) - Friday, 18 August 2006, 11:26 GMT
Nice solution !!!
It's not a big problem, but sometimes is speed a factor to win or to loose a game.

OS: Microsoft Windows XP [versie 5.1.2600]

Comment by KUDr (KUDr) - Monday, 13 November 2006, 21:34 GMT
Here is some patch (against r7138) that solves the problem. Not only keys were lost but also mouse clicks. But just now this patch helps only on win32 platform. Other drivers (sdl, cocoa) will need similar changes too.

Comment by KUDr (KUDr) - Wednesday, 15 November 2006, 12:51 GMT
Updated patch (v4 against r7151) that should have it solved for both SDL and Win32 drivers.
Comment by KUDr (KUDr) - Wednesday, 15 November 2006, 14:51 GMT
Here are handled also keys for cocoa (dunno if it will work):

Loading...