OpenTTD

Tasklist

FS#2253 - NOT_REACHED error with hard-coded path?

Attached to Project: OpenTTD
Opened by Pim Rupert (prupert) - Sunday, 24 August 2008, 09:50 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 14 September 2008, 10:32 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Medium
Priority Normal
Reported Version 0.6.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
  • Pim Rupert (prupert) (2008-08-24)
Private No

Details

The game crashes with a remarkable error message, because the path of the file in the error message is non-existant ('Volumes/Macintosh/Users/bjarni') and probably from a developer (hard-coded?).

Error:
NOT_REACHED triggered at line 458 of /Volumes/Macintosh/Users/bjarni/spil/openttd/release/0.6.2/src/airport.cpp
This task depends upon

Closed by  Remko Bijker (Rubidium)
Sunday, 14 September 2008, 10:32 GMT
Reason for closing:  Unreproducible
Comment by Zdeněk Sojka (SmatZ) - Sunday, 24 August 2008, 12:33 GMT
It seems there is an invalid airport type somewhere.
Could you post a savegame with a description what to do to reproduce this problem?
Comment by Loïc GUILLOUX (glx) - Sunday, 31 August 2008, 13:35 GMT
The "invalid" path is not related to the crash ;) (it's just the result of __FILE__ and __LINE__ in NOT_REACHED() macro)

Loading...