OpenTTD

Tasklist

FS#2111 - Trains stuck loading after being full

Attached to Project: OpenTTD
Opened by kramer (kramer) - Thursday, 26 June 2008, 14:39 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Alright, r13638, compiled it myself.

I was nicely playing, build a new coal route, added 2 more trains (having a total of four now) and fast forwarded. Once I made some money, I went in to replace the trains with autoreplace. Fine. Here the problems began. Only one was replaced, and then they went to the stations and started loading. Except that they're loading forever, some are full, but still loading (only coal wagons and a break wagon, UKRS). I've passed years on FF and I found myself in debt over 1 million euros!!! I saved, then quite OpenTTD and it crashed while quitting.

Here is a list of the NewGRFs used (files zipped & attached so you don't have to search for them):

[newgrf]
newgrfOpenGFX_-_newEyeCandy_v0.2.grf
newgrfOpenGFX_-_newGUI_v0.2.grf
newgrfOpenGFX_-_newInfrastructure_v0.4.grf
newgrfOpenGFX_-_newlandscape_v0.3.grf
newgrfOpenGFX_-_newTerrain_v0.4.grf
newgrfpikkindw.grf
newgrfxmas.grf = 1
newgrfgrassyknoll.grf = 1
newgrftotal_bridges.grf = 2
newgrfbuffers.grf
newgrfnewstatsw.grf
newgrfindstatrw.grf = 0 0
newgrfpb_ukrs.grf = 0 3 0
newgrfpb_av8w.grf
newgrfgrvts.grf
newgrfshiptoolv4.grf = 500 250
newgrfpb_build.grf
This task depends upon

Closed by  Remko Bijker (Rubidium)
Thursday, 26 June 2008, 14:43 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Of  FS#2038  ; not exactly but the cause is be *exactly* the same.

Loading...