OpenTTD

Tasklist

FS#2098 - Crash of Order GUI

Attached to Project: OpenTTD
Opened by Remko Bijker (Rubidium) - Saturday, 21 June 2008, 21:13 GMT
Last edited by frosch (frosch) - Wednesday, 06 August 2008, 19:01 GMT
Type Bug
Category Vehicles → Autoreplace
Status Closed
Assigned To Bjarni (Bjarni)
Operating System All
Severity Critical
Priority High
Reported Version trunk
Due in Version 0.7.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r13602: crash due to drawing Order GUI of a non-existing vehicle.

Steps to reproduce:
- build depot
- build train
- open train's order list
- set autoreplace to replace the train
- let autoreplace be performed on the train
- NOT_REACHED gets triggered.
This task depends upon

Closed by  frosch (frosch)
Wednesday, 06 August 2008, 19:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r14007

Loading...