OpenTTD

Tasklist

FS#1976 - Fix for FS1975 not working

Attached to Project: OpenTTD
Opened by 3iff (3iff) - Friday, 02 May 2008, 12:48 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Nightly 12930 + fix from FS1975 recompiled but doesn't fix the problem.

Simple test with a bus running between 2 stations, on entering station, a manual "goto depot" click is forgotten and road vehicle returns to original station.
This task depends upon

Closed by  Jean-Francois Claeys (Belugas)
Thursday, 03 July 2008, 14:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Seems that r13664, for  FS#2117  , did the job.
Requested by Yexo
Comment by Yorick (yorick) - Tuesday, 06 May 2008, 15:32 GMT
It is fixed in r12935, so the nightly r12930 doesn't include that fix. Try it with a newer version.
Comment by Zdeněk Sojka (SmatZ) - Wednesday, 21 May 2008, 22:32 GMT
I fail to reproduce that. Can you with current nightly, Gary?
Comment by 3iff (3iff) - Thursday, 22 May 2008, 07:33 GMT
Tested nightly 13205 and it still fails. Just as the vehicle is entering the station, click its depot button to force a depot visit/service. The vehicle enters the station and then reports 'leaving' to head to the depot, exits the station and then returns to the station having forgotten the depot order.

Savegame not necessary as it's easy to set up two bus stations and a bus to prove the problem.
Comment by Zdeněk Sojka (SmatZ) - Thursday, 22 May 2008, 23:09 GMT
Savegame would be useful. To show the problem and to simplify reproduction, debugging and fixing.
Ideally paused in a moment when the vehicle should be sent to a depot.
Comment by 3iff (3iff) - Friday, 23 May 2008, 07:18 GMT
Ok, as requested...savegame enclosed. Nightly 13205 no grfs.

Start game paused, open vehicle 1 window, restart game and control/click depot to force a manual service visit.
Vehicle recognises instruction, enters station (because it's going that way), reports "leaving" and then switches instruction to visit the station again, forgetting the service order.

Hope this helps. PM me if you need more...
Comment by Zdeněk Sojka (SmatZ) - Friday, 23 May 2008, 11:57 GMT
Thanks. I was testing with drive-thru road stations.
Comment by 3iff (3iff) - Friday, 23 May 2008, 13:11 GMT
Ahh, rarely use drivethroughs, perhaps that's why you weren't seeing the problem. Good luck.

Loading...