OpenTTD

Tasklist

FS#1515 - stations & build on slopes

Attached to Project: OpenTTD
Opened by Fragster (Fragster) - Friday, 07 December 2007, 11:16 GMT
Last edited by andythenorth (andythenorth) - Wednesday, 16 August 2017, 09:39 GMT
Type Feature Request
Category Core
Status Closed
Assigned To andythenorth (andythenorth)
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

when buildonslopes included, I can build a station on the slope along it, but I can not build across the slope, if station should "hang" on the slope :(


in r11576 & earlier
This task depends upon

Closed by  andythenorth (andythenorth)
Wednesday, 16 August 2017, 09:39 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Won't implement. Flying train bug. Not a current goal for OpenTTD.
Comment by Fragster (Fragster) - Friday, 07 December 2007, 11:18 GMT
*included <=> is on
Comment by Remko Bijker (Rubidium) - Friday, 07 December 2007, 19:49 GMT
This is not a bug. This is done so by design. Either entrance/exit should be connectable when build, otherwise the AI is going to be even crappier.
Comment by Fragster (Fragster) - Monday, 10 December 2007, 08:18 GMT
But what about termius stations? if landscape is very rough, this 1 tile may be very useful.
Comment by Jean-Francois Claeys (Belugas) - Wednesday, 12 December 2007, 03:04 GMT
I guess you should have to adjust landscape adequately before constructing...
Comment by Fragster (Fragster) - Wednesday, 12 December 2007, 08:00 GMT
in some cases landscape cant be adjusted, or it is very expencible (if it is the edge of the map, or mountain directly on coast...)
Comment by andythenorth (andythenorth) - Tuesday, 27 December 2016, 13:43 GMT
I patched for building stations on the slopes once. It causes a flying train bug if track is connected at the sloped end, trains will literally ascend 1 height level vertically.

TMWTFLB to fix, even though it would be a nice feature. Should be closed.

Loading...