OpenTTD

Tasklist

FS#1461 - Missing LV4 Refit Sprites in Nightly

Attached to Project: OpenTTD
Opened by Arthur Pallas (athanasios) - Tuesday, 20 November 2007, 23:07 GMT
Last edited by Remko Bijker (Rubidium) - Saturday, 15 December 2007, 23:03 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 0.6.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Refit sprites for LV4 are not displayed. All refit vehicles display same sprite.
Tested on win32 with new game, only LV4 grf loaded to exclude grf conflicts.

Versions affected: 0.6.0-beta 1 and nightlies after it.

Discussion thread: https://www.tt-forums.net/viewtopic.php?f=31&t=34948
This task depends upon

Closed by  Remko Bijker (Rubidium)
Saturday, 29 December 2007, 23:49 GMT
Reason for closing:  Fixed
Comment by Jean-Francois Claeys (Belugas) - Friday, 14 December 2007, 18:57 GMT
although it has been verified that it actually works on our side, George, it is reopened.
Now: it would be nice if you could provide grf as well as screenshots of good and bad behaviour
Comment by George (George) - Friday, 14 December 2007, 19:07 GMT
the same grf, 2 s different screen shots
(application/octet-stream)    4LVw.grf (2.24 MiB)
   11588.png (154.9 KiB)
   11629.png (215.3 KiB)
Comment by Remko Bijker (Rubidium) - Saturday, 15 December 2007, 23:03 GMT
For me 11629 works as intended with the provided NewGRF.
Comment by George (George) - Sunday, 16 December 2007, 06:34 GMT
config
Comment by Remko Bijker (Rubidium) - Sunday, 16 December 2007, 20:47 GMT
Can you post a savegame that shows this behaviour?
Comment by George (George) - Sunday, 16 December 2007, 21:26 GMT
Do not watch at coal mine like iron ore mines industry - it is a test grf for iron ore mine used, just ignore it. If necessary, I can make a blank game.
Comment by Remko Bijker (Rubidium) - Sunday, 16 December 2007, 22:22 GMT
Seems rather like a local configuration problem to me. Anyhow, looks like TTDP disables the NewGRF in that case, so we should too.
   fs1461.png (117.9 KiB)
Comment by George (George) - Monday, 17 December 2007, 05:59 GMT
Yes, you should. But why does it loading after error? The GRF should be totally disabled (and marked red), doesn't it?

P.S. Yes, reordering files fixes the display problem, but it is rather confusing that GRF with error is still loading.
Comment by Remko Bijker (Rubidium) - Monday, 17 December 2007, 08:23 GMT
Because the persons who have messed with implementing Action 7 did not understand the NewGRF specs completely it did not disable the NewGRF, it just skipped all 'next' sprites. Anyhow... *if* a NewGRF should be disabled with an error, why don't you use the Action B 'fatal error' that immediately disables the NewGRF instead of relying on yet another piece of NewGRF?

Anyhow, that not-completely-correctly-implemented-Action-7 issue should be solved in the current trunk.
Comment by George (George) - Monday, 17 December 2007, 16:37 GMT
With fatal error you can't load the grf unless you restart TTDp. In current situation you can fix error by disabling ECS files after LV4, so the error is not fatal.
Comment by Remko Bijker (Rubidium) - Monday, 17 December 2007, 21:09 GMT
Anyhow... is it better in today's nightly?
Comment by George (George) - Tuesday, 18 December 2007, 04:52 GMT
I loaded the save, got the error as intended, reordered the files (moved LV4 to the end), pressed applay... Error disappeared, but file stayed disabled without reporting a reason for disabling. I supposed it to become enabled :(
Comment by Fragster (Fragster) - Tuesday, 18 December 2007, 08:51 GMT
I guess this bug appears not only with LV4... same thing happens with UKRS from Pikkabird
Comment by Remko Bijker (Rubidium) - Saturday, 29 December 2007, 23:40 GMT
Those wagons are different because they are different mineral wagons (they are not equal in length).

Loading...