OpenTTD

Tasklist

FS#917 - Load scenario with no towns failed.

Attached to Project: OpenTTD
Opened by Bilbo (bilbo) - Friday, 22 June 2007, 18:04 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In r10267, when I create screnario without any towns at all (like the one attached), loading the scenario will fail.

Either this should be fixed, so towns won't be required, or (if no towns will break the game logic too much) some more explanatory error message explaining the cause instead of just "Game Load failed" should be printed out (Like "The scenario need at least one town").
This task depends upon

Closed by  Remko Bijker (Rubidium)
Sunday, 24 June 2007, 12:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r10300.

Loading...