OpenTTD

Tasklist

FS#901 - Assertion failure

Attached to Project: OpenTTD
Opened by immeR (immeR) - Wednesday, 20 June 2007, 22:14 GMT
Last edited by KUDr (KUDr) - Wednesday, 20 June 2007, 22:51 GMT
Type Bug
Category Vehicles → YAPF
Status Closed
Assigned To KUDr (KUDr)
Operating System Linux
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Seems to me, that my style of playing OTTD is a tough challenge for yapf ;)
A year has passed in-game from the report #884 and here we are again.

System : Celeron D320 with 512MB RAM aboard; Ubuntu 6.06
OTTD r10239, bleeding edge =)

Steps to reproduce:
- load autosave3 , yes, it's autosave3 again =)
- wait for Jun 10

Result:
Assertion fails, stating there is something wrong with yapf

Regards, Denis.
This task depends upon

Closed by  KUDr (KUDr)
Sunday, 24 June 2007, 14:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  r10301 /trunk/src/yapf/ (6 files): -Fix [ FS#901 , YAPF]: another assert violation in some special cases (immeR)
Comment by KUDr (KUDr) - Wednesday, 20 June 2007, 22:50 GMT
Thanks for another report. I don't know if I will be able to look at it before weekend so please be patient. For now you can disable asserts and play. Assert itself is not a bug. It can be sign of some unexpected condition so code can still work normally if asserts are disabled.
Comment by KUDr (KUDr) - Sunday, 24 June 2007, 12:47 GMT
Here is proposed fix. It needs more testing before I can commit it. Can you please try it?
Apply it to r10300.
thanks

Loading...