OpenTTD

Tasklist

FS#882 - Can't raise/lower land with diagonal rails with certain slopes

Attached to Project: OpenTTD
Opened by oxygene (oxygene) - Saturday, 16 June 2007, 22:09 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 0.5.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Please see the attached image. It is possible to terraform towards a situation with a N, E, S or W slopes only but no way out of it without having to rebuild the rail.
The reason for this behavior seems to lie in clear_cmd.cpp in the function TerraformProc. There is an array of "unsafe slopes" and a comment about a bug that needs to be avoided. However, I don't understand why these would be unsafe. I've removed the check and could not find any unexpected situations.

Please tell me if I miss something.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 19 June 2007, 15:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r10219.
Comment by Remko Bijker (Rubidium) - Saturday, 16 June 2007, 22:28 GMT
What's (probaly) meant that "unsafe slopes" are slopes where the slope of the foundation changes when terraforming occurs, which is, by the way, implemented badly in this case.
Comment by oxygene (oxygene) - Saturday, 16 June 2007, 23:50 GMT
Well, the question is what the expected behavior is. However, either all 4 cases in the PNG should fail or succeed. (I'm pleading for succeeding)

Loading...